Если больше или равно в excel

Если больше или равно в excel

Функция ЕСЛИ

​Смотрите также​ «СУММ» используется для​ цену в 2​ кругозора спасибО)))​Видео: усложненные функции ЕСЛИ​возвращает значение ИСТИНА;​=ЕСЛИ(И(B14>=$B$7,C14>=$B$5),B14*$B$8,0)​Аргумент​

​В Excel существуют логические​ Например, это функции​ с другими функциями.​ формулу.​

​ которое мы укажем​ двух аргументов или​Если у простой функции​ требуется изменять) не​ дополнительные вычисления в​Функция ЕСЛИ — одна из​

​ подсчета итогового балла.​ раза.​Владимир​Использование вложенных функций​ если он имеет​ —​Описание​ функции​

Технические подробности

​ ЕСЛИ, СЧЕТЕСЛИ, СУММЕСЛИ​=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B11;НАИМЕНЬШИЙ(ЕСЛИ($F$2=A2:A11;СТРОКА(B2:B11)-1;»»);​=ЕСЛИ(A4=»Да»;100;»»)​ в формуле. Можно​ значение ИСТИНА/ЛОЖЬ.​ ЕСЛИ есть только​

​ рекомендуется вводить прямо​

​ зависимости от условий.​

​ самых популярных функций​

​Функция ЕСЛИ позволяет решать​

​Сформируем таблицу с исходными​

​ значение ИСТИНА, функция​​ЕСЛИ​

​СТРОКА()-5));»»)​Обратите внимание!​​ выбрать любые числа,​​»#ИМЯ?» в ячейке​

​ два результата (ИСТИНА​​ в формулу, поскольку​

​ Для выполнения нескольких​ в Excel. Она​​ многочисленные задачи, поэтому​​ параметрами:​

Простые примеры функции ЕСЛИ

​Логические функции в Excel​

​Функция ЕСЛИ​НЕ​​общие продажи больше​Обязательный аргумент. Первое проверяемое​и​

​ логические условия можно​

​Эта формула для​В третьем условии​​ слова, т.д.​Как правило, это указывает​ и ЛОЖЬ), то​ в будущем их​

​ сравнений можно использовать​ позволяет выполнять логические​ используется чаще всего.​Чтобы решить поставленную задачу,​ проверяют данные и​Функция И​возвращает значение ЛОЖЬ.​ или равны (>=)​ условие, вычисление которого​ЛОЖЬ()​ задавать в обычных​ примера взята из​ в формуле мы​Появившееся диалоговое окно​ на ошибку в​ у вложенных функций​ может быть затруднительно​ несколько вложенных функций​ сравнения значений и​

​Задача 1. Проанализировать стоимость​​ воспользуемся логической функцией​ возвращают результат «ИСТИНА»,​Функция ИЛИ​Ниже представлено несколько общих​ целевым продажам​ дает значение ИСТИНА​, которые не имеют​

Начало работы

​ формулах, если необходимо​ статьи «Выбрать сразу​ поставили не «нуль»,​ заполнили так.​ формуле.​ ЕСЛИ может быть​ найти и изменить.​ ЕСЛИ.​ ожидаемых результатов. Самая​ товарных остатков после​ ЕСЛИ. Формула будет​ если условие выполняется,​Полные сведения о​ примеров использования функции​И​ или ЛОЖЬ.​ аргументов. Данные функции​ получить утвердительный ответ:​ много данных из​ а две двойные​В формуле «ЕСЛИ» нужно​Видео: расширенное применение функции​ от 3 до​

Еще примеры функции ЕСЛИ

​ Гораздо удобнее помещать​

​Примечание:​ простая функция ЕСЛИ​ уценки. Если цена​​ выглядеть так: =ЕСЛИ(C2>=8;B2/2;B2).​ и «ЛОЖЬ», если​ формулах в Excel​НЕ​число договоров больше​

B2;C2-B2;»>

​ существуют в основном​Да​ таблицы Excel» здесь.​ кавычки – это​ написать три условия.​​ ЕСЛИ​ 64 результатов.​ константы в собственные​ Если вы используете текст​ означает следующее:​ продукта после переоценки​​Логическое выражение «С2>=8» построено​

​Рекомендации, позволяющие избежать​как отдельно, так​ или равно (>=)​​Необязательный аргумент. Дополнительные проверяемые​ для обеспечения совместимости​или​ Этой формулой выбираем​ значит «Пусто» (оставить​ В формуле эти​Функция ЕСЛИМН (Office 365, Excel 2016​=ЕСЛИ(D2=1;»ДА»;ЕСЛИ(D2=2;»Нет»;»Возможно»))​

​ ячейки, в которых​

​ в формулах, заключайте​ЕСЛИ(это истинно, то сделать​ ниже средних значений,​ с помощью операторов​Рассмотрим синтаксис логических функций​ появления неработающих формул​ и в сочетании​ целевому, общие продажи​ условия, вычисление которых​ с другими электронными​Нет​ из таблицы товара​ ячейку пустой). Скопировали​ условия напишутся через​ и более поздние​Показанная на рисунке выше​ они будут доступны​ его в кавычки​ это, в противном​ то списать со​ отношения «>» и​ и примеры применения​Поиск ошибок в​ с функциями​ умножаются на процент​ дает значение ИСТИНА​ таблицами. Вы можете​. К примеру, задавая​ и переносим в​ формулу в ячейку​ точку с запятой.​ версии)​

Операторы вычислений

​ формула в ячейке​ и их можно​ (пример: «Текст»). Единственное​ случае сделать что-то​ склада этот продукт.​​ «=». Результат его​​ их в процессе​​ формулах​​ЕСЛИ​​ премии. В противном​​ или ЛОЖЬ. Условий​ вводить значения ИСТИНА​ простые логические условия,​ лист заказа выбранные​

Использование функции ЕСЛИ для проверки ячейки на наличие символов

​ В5.​Первое условие –​Усложненные функции ЕСЛИ: как​ E2 означает:​ будет легко найти​ исключение — слова ИСТИНА​

​ еще)​Работаем с таблицей из​ вычисления – логическая​

​ работы с программой​

​Сочетания клавиш и​​,​ случае возвращается значение​ может быть не​ и ЛОЖЬ прямо​​ Вы можете ответить​ покупателем позиции.​Третий пример.​ «Лог_выражение». Мы написали​ работать с вложенными​ЕСЛИ(D2 равно 1, то​ и изменить. В​ и ЛОЖЬ, которые​

​Поэтому у функции ЕСЛИ​

​ предыдущего раздела:​​ величина «ИСТИНА» или​ Excel.​ горячие клавиши в​И​ 0.​​ более 255.​ в ячейки или​ на такие вопросы:​Ещё есть функция​В следующей формуле​ А1=2 – это​

​ формулами и избежать​

​ вернуть текст «Да»,​ нашем случае все​ Excel распознает автоматически.​ возможны два результата.​​Для решения задачи используем​

Пример вложенных функций ЕСЛИ

​ «ЛОЖЬ». В первом​Название функции​ Excel​и​Видео: усложненные функции ЕСЛИ​Примечания​ формулы, не используя​5 больше 8?​

​ «СЧЁТЕСЛИ» в Excel​

​ поставили в третьем​ значит, если в​ ошибок​​ в противном случае​ в порядке, так​Прежде чем написать оператор​ Первый результат возвращается​ формулу вида: .​ случае функция возвращает​Значение​Сочетания клавиш в​​ИЛИ​Использование вложенных функций​Аргументы должны давать в​ форму записи функции,​Содержимое ячейки A5 меньше​ — она считает​ условии знак «Тире».​ ячейке А1 стоит​Обучающие видео: усложненные функции​ ЕСЛИ(D2 равно 2,​ как здесь используется​

Небольшое предупреждение

​ ЕСЛИ, подумайте, чего​ в случае, если​ В логическом выражении​ значение «В2/2». Во​Синтаксис​ Excel 2016 для Mac​

​.​ в формуле​ результате логические значения​ Excel все прекрасно​ 8?​ количество ячеек по​ =ЕСЛИ(A5=»Да»;100;»-«)​ цифра 2. Мы​ ЕСЛИ​ то вернуть текст​ только одна функция​ вы хотите достичь.​ сравнение истинно, второй —​ «D2​ втором – «В2».​Примечание​Логические функции (ссылка)​

​Формула​Функция ЕСЛИ​ (такие как ИСТИНА​ поймет.​А может равно 8?​ нашим условиям. Смотрите​В ячейку В6​ написали условие, по​Подсчет значений на основе​ «Нет», в противном​

​ ЕСЛИ, а ставка​ Какое сравнение вы​ если сравнение ложно.​Задача 2. Найти средние​Усложним задачу – задействуем​ИСТИНА​Функции Excel (по​

Распространенные неполадки

​Если Вы уверены, что​​В Excel имеется ряд​​ статью «Функция «СЧЁТЕСЛИ​​ написали такую формулу.​​ которому нужно искать​ одного условия с​ случае вернуть текст​ налога с продажи​

​ пытаетесь выполнить? Написать​

​Если вы ищете информацию​ продажи в магазинах​ логическую функцию И.​

​Не имеет аргументов, возвращает​ алфавиту)​

​=НЕ(A2>100)​Функция НЕ​ быть массивами или​

​ уже достаточно хорошо​ стандартных операторов, которые​ в Excel». Эту​ =ЕСЛИ(A6=»%»;1;»нет») Здесь в​

​ ячейки в столбце​ помощью функции СЧЁТЕСЛИ​

​ «Возможно»)).​ будет редко изменяться.​ оператор ЕСЛИ не​

​ о работе с​ сети.​ Теперь условие такое:​

​ логическое значение «ИСТИНА».​Функции Excel (по​A2​

​Полные сведения о​ ссылками, содержащими логические​ освоили эту тему,​

​ используются для задания​

​ функция может посчитать​

​ третьем условии написали​

​ А (ячейки, в​Подсчет значений на основе​

​Обратите внимание на​ Даже если она​

​ сложнее, чем выстроить​ несколькими операторами ЕСЛИ,​Составим таблицу с исходными​

​ если товар хранится​

Функция «ЕСЛИ» в Excel.

Как задать простое логическое условие в Excel

​ с функцией​ все ли проверяемые​ в противном случае.​ Excel ячейки в​ С1 слово «Да».​ «6». Можно написать​ с помощью функции​Нужно очень крепко подумать,​ приоритеты.​=ЕСЛИ(C2>B2;»Превышение бюджета»;»В пределах бюджета»)​Имя аргумента​​ В9 – условие.​​ или продукт хранится​​ «ЛОЖЬ».​​ Как так сделать?​ значение ЛОЖЬ.​ убедиться, что одно​ЕСЛИ​

  • ​ условия принимают значение​
  • ​ Задавая такое условие,​ определенных строках».​
  • ​ Если число будет​

Операторы сравнения в Excel

​ любое слово в​ проверки ошибок​ чтобы выстроить последовательность​Иногда требуется проверить, пуста​В примере выше функция​Описание​ Третий аргумент –​

Как задать условие в Excel

​ дольше 10 месяцев,​=И (Лог_знач. 1; Лог_знач.​И скажить как​=ЕСЛИ(ИЛИ(НЕ(A350)); A3; «Значение вне​ значение не равно​.​

​ ИСТИНА.​​ можно сравнивать текстовые​Можно в Excel​ меньше 2, то​ этом условии, т.д.​Логические функции​ из множества операторов​ ли ячейка. Обычно​ ЕСЛИ в ячейке​лог_выражение​ $C$2:$C$7 – диапазон​ его списывают.​ 2;…)​ написать чтоб EXCEL​

​ интервала»)​​ другому.​Формула​Функция​ строки без учета​ суммировать данные из​ ячейка должна оставаться​Третье условие –​Функции Excel (по алфавиту)​ ЕСЛИ и обеспечить​ это делается, чтобы​

​ D2 означает:​ (обязательно)​ усреднения; числовые значения,​Для решения используем логические​Принимает до 255 аргументов​ понял что надо​100 не меньше 0​Функция​Описание​И​

​ регистра. К примеру,​ таблицы по многим​ пустой. Скопировали формулу​ «Значение_если_ложь» — здесь​Функции Excel (по категориям)​ их правильную отработку​ формула не выводила​

​ЕСЛИ(C2 больше B2, то​​Условие, которое нужно проверить.​ которые берутся для​ функции ЕСЛИ и​ в виде условий​ «Больше или равно»,»Меньше​ (ЛОЖЬ) и больше​

​НЕ​=И(A2>1;A2​​возвращает значение ИСТИНА,​​ сравнивая «ЯНВАРЬ» и​​ разным условиям. Например,​​ по столбцу С.​ мы напишем, что​Часто применяемая,​ по каждому условию​ результат при отсутствии​ вернуть текст «Превышение​значение_если_истина​ расчета среднего арифметического.​ ИЛИ: =10);»списан»;»»)’ class=’formula’>.​ или ссылок. Обязательным​ или равно», «Не​ чем 50 (ИСТИНА),​меняет значение своего​

​Возвращает значение ИСТИНА, если​ если в результате​ «январь» формула возвратит​ в функции «ЕСЛИ»​ Получилось так.​ нужно писать, если​логическая функция в Excel​ на протяжении всей​ входного значения.​ бюджета», в противном​​ (обязательно)​​Функция СРЗНАЧЕСЛИ сопоставляет значение​​ Условие, записанное с​​ является первый.​

​ ровняется». Так для​

​ поэтому функция​​ аргумента на обратное.​ число в ячейке​ вычисления всех аргументов​ ИСТИНА.​ можно написать одно​Пятый пример.​

Технические подробности

​ в ячейке А1​​ — функция «ЕСЛИ»​​ цепочки. Если при​В данном случае мы​ случае вернуть текст​Значение, которое должно возвращаться,​ ячейки В9 (№1)​ помощью логической операции​ИЛИ​ кругозора))))​НЕ​

​Обычно функция​​ A2 больше 1​​ получается значение ИСТИНА,​=A1>B1​ условие поиска данных​Можно функцией «ЕСЛИ»​​ будет написано НЕ​​считает данные ячеек​ вложении операторов ЕСЛИ​ используем ЕСЛИ вместе​ «В пределах бюджета»)​ если​ со значениями в​ ИЛИ, расшифровывается так:​Показывает результат «ИСТИНА», если​​Шит​​изменяет значения аргументов​​НЕ​​И​​ и значение ЛОЖЬ,​​— Следующая формула​ для суммирования. В​ посчитать итог теста,​

​ по условию, которое​​ вы допустите малейшую​

​ с функцией ЕПУСТО:​​=ЕСЛИ(C2>B2;C2-B2;0)​​лог_выражение​

Источник:
http://my-excel.ru/excel/esli-bolshe-ili-ravno-v-excel.html

Как в excel сделать больше или равно?

Такие выражения, как «больше или равно», «меньше или равно» и «не равно», могут быть очень полезны при анализе данных.

Эти операторы используют сравнения двух значений, и результатом сравнения будет ИСТИНА или ЛОЖЬ.

Обратите внимание, что логические операторы сравнивают значения независимо от того, было ли оно введено напрямую или было создано с помощью формулы. Эти операторы сравнивают именно значения. Не формулы.

Равно (=) и не равно ()

Эти операторы просты: они говорят вам, являются ли два значения равными или не равными друг другу:

Читайте также  Как сделать диаграмму по таблице в Экселе

Эти операторы равно и не равно также работают с текстом:

Больше (>) и меньше () – если первое значение больше второго, результатом будет ИСТИНА Оператор меньше ( =) и меньше или равно ( =) – если первое значение больше второго или равно ему, результатом будет ИСТИНА Оператор меньше или равно (
Название форума Темы Сообщения Обновление Здесь можно получить ответы на вопросы по Microsoft Excel 58627 479886 13 Ноя 2018 01:32:48 44519 357825 29 Янв 2017 17:28:40 Лучшие избранные темы с основного форума 14 80 28 Июн 2018 15:25:11 Если вы — счастливый обладатель Mac 220 1066 11 Ноя 2018 04:30:45 Раздел для размещения платных вопросов, проектов и задач и поиска исполнителей для них. 2149 13707 12 Ноя 2018 23:19:09 Если Вы скачали или приобрели надстройку PLEX для Microsoft Excel и у Вас есть вопросы или пожелания — Вам сюда. 317 1617 12 Ноя 2018 14:23:59 824 11982 12 Ноя 2018 14:08:08 Обсуждение функционала, правил и т.д. 270 3481 30 Окт 2018 15:01:36 Сейчас на форуме (гостей: 426, пользователей: 5, из них скрытых: 1) , , , Сегодня отмечают день рождения (35), (32), (31) Всего зарегистрированных пользователей: 83968 Приняло участие в обсуждении: 32196 Всего тем: 106940

Если такие знаки сравнения, как «больше» (>) и «меньше» (
Функция ЕСЛИ Функции И, ИЛИ, НЕ Вложенные функции ЕСЛИ Функции ИСТИНА и ЛОЖЬ Функция ЕПУСТО Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые или логические значения. Любое логическое выражение должно содержать по крайней мере один оператор сравнения, который определяет отношение между элементами логического выражения. Ниже представлен список операторов сравнения Excel = Равно > Больше >= Больше или равно Не равно Результатом логического выражения является логическое значение ИСТИНА (1) или логическое значение ЛОЖЬ (0). Функция ЕСЛИ

Функция ЕСЛИ (IF) имеет следующий синтаксис:

=ЕСЛИ(логическое_выражение;значение_если_истина;значение_если_ложь)

Следующая формула возвращает значение 10, если значение в ячейке А1 больше 3, а в противном случае — 20:

В качестве аргументов функции ЕСЛИ можно использовать другие функции. В функции ЕСЛИ можно использовать текстовые аргументы. Например:

=ЕСЛИ(А1>=4;»Зачет сдал»;»Зачет не сдал»)

Можно использовать текстовые аргументы в функции ЕСЛИ, чтобы при невыполнении условия она возвращала пустую строку вместо 0.

Аргумент логическое_выражение функции ЕСЛИ может содержать текстовое значение. Например:

Эта формула возвращает значение 10, если ячейка А1 содержит строку «Динамо», и 290, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.

Функции И, ИЛИ, НЕ

Функции И (AND), ИЛИ (OR), НЕ (NOT) — позволяют создавать сложные логические выражения. Эти функции работают в сочетании с простыми операторами сравнения. Функции И и ИЛИ могут иметь до 30 логических аргументов и имеют синтаксис:

=И(логическое_значение1;логическое_значение2…)
=ИЛИ(логическое_значение1;логическое_значение2…)

Функция НЕ имеет только один аргумент и следующий синтаксис:

=НЕ(логическое_значение)

Аргументы функций И, ИЛИ, НЕ могут быть логическими выражениями, массивами или ссылками на ячейки, содержащие логические значения.

Приведем пример. Пусть Excel возвращает текст «Прошел», если ученик имеет средний балл более 4 (ячейка А2), и пропуск занятий меньше 3 (ячейка А3). Формула примет вид:

=ЕСЛИ(И(А2>4;А3

Не смотря на то, что функция ИЛИ имеет те же аргументы, что и И, результаты получаются совершенно различными. Так, если в предыдущей формуле заменить функцию И на ИЛИ, то ученик будет проходить, если выполняется хотя бы одно из условий (средний балл более 4 или пропуски занятий менее 3). Таким образом, функция ИЛИ возвращает логическое значение ИСТИНА, если хотя бы одно из логических выражений истинно, а функция И возвращает логическое значение ИСТИНА, только если все логические выражения истинны.

Функция НЕ меняет значение своего аргумента на противоположное логическое значение и обычно используется в сочетании с другими функциями. Эта функция возвращает логическое значение ИСТИНА, если аргумент имеет значение ЛОЖЬ, и логическое значение ЛОЖЬ, если аргумент имеет значение ИСТИНА.

Вложенные функции ЕСЛИ

Иногда бывает очень трудно решить логическую задачу только с помощью операторов сравнения и функций И, ИЛИ, НЕ. В этих случаях можно использовать вложенные функции ЕСЛИ. Например, в следующей формуле используются три функции ЕСЛИ:

=ЕСЛИ(А1=100;»Всегда»;ЕСЛИ(И(А1>=80;А1=60;А1

Если значение в ячейке А1 является целым числом, формула читается следующим образом: «Если значение в ячейке А1 равно 100, возвратить строку «Всегда». В противном случае, если значение в ячейке А1 находится между 80 и 100, возвратить «Обычно». В противном случае, если значение в ячейке А1 находится между 60 и 80, возвратить строку «Иногда». И, если ни одно из этих условий не выполняется, возвратить строку «Никогда». Всего допускается до 7 уровней вложения функций ЕСЛИ.

Функции ИСТИНА и ЛОЖЬ

Функции ИСТИНА (TRUE) и ЛОЖЬ (FALSE) предоставляют альтернативный способ записи логических значений ИСТИНА и ЛОЖЬ. Эти функции не имеют аргументов и выглядят следующим образом:

=ИСТИНА()
=ЛОЖЬ()

Например, ячейка А1 содержит логическое выражение. Тогда следующая функция возвратить значение «Проходите», если выражение в ячейке А1 имеет значение ИСТИНА:

В противном случае формула возвратит «Стоп».

Функция ЕПУСТО

Если нужно определить, является ли ячейка пустой, можно использовать функцию ЕПУСТО (ISBLANK), которая имеет следующий синтаксис:

=ЕПУСТО(значение)

Аргумент значение может быть ссылкой на ячейку или диапазон. Если значение ссылается на пустую ячейку или диапазон, функция возвращает логическое значение ИСТИНА, в противном случае ЛОЖЬ.

Источник:
http://word-office.ru/kak-v-excel-sdelat-bol-she-ili-ravno.html

Логические операции в Excel

Логическая – это такая разновидность функции, которая может возвращать одно из возможных значений – истинное, если содержатся внутри ячейки значения, подпадающее под определенный критерий и ложное, если этого не происходит. Используются логические функции с целью программирования электронных таблиц с целью добиться разгрузки себя от часто повторяющихся действий.

Кроме этого, логические функции могут применять с целью проверить, в какой мере содержимое ячейки соответствует определенному критерию. Также могут проверяться и другие логические значения.

Операторы сравнения

Каждое выражение содержит операторы сравнения. Они бывают следующими:

  1. = – значение 1 равно значению 2.
  2. > – значение 1 больше значения 2.
  3. = значение 1 или идентично значению 2, или больше него.
  4. значение 1 или больше значения 2 или меньше него.

Как следствие, Excel выдает один из двух возможных результатов: истина (1) или ложь (2).

Для применения логических функций необходимо во всех возможных случаях задавать условие, содержащее одно или несколько операторов.

Функция «Истина»

Для использования этой функции не нужно указывать никаких аргументов, и она всегда возвращает «Истина» (что соответствует цифре 1 двоичной системы счисления).

Пример формулы – =ИСТИНА() .

Функция «Ложь»

Функция, полностью аналогичная предыдущей, только возвращаемый ею результат – «Ложь». Самая легкая формула, где можно использовать эту функцию, следующая =ЛОЖЬ().

Задачей этой формулы является возвращение значения «Истина» при соответствии каждого из аргументов определенному значению или определенному критерию, которые описаны выше. Если вдруг возникает несоответствие одного из критериев требуемому, то возвращается значение «Ложь».

Ссылки на ячейки с логическими значениями также применяются в качестве параметров функции. Максимальное количество аргументов, которые можно использовать – 255. Но обязательное требование – наличие хотя бы одного из них в скобках.

Синтаксис этой функции такой:

= И(Логическое значение1; [Логическое значение 2];…)

На данном скриншоте видно, что каждый аргумент передает истинное значение, поэтому в результате использования этой формулы можно получить соответствующий результат.

Функция «Или»

Проверяет несколько значений на предмет соответствия определенному критерию. Если какой-то из них соответствует, то функция возвращает истинное значение (1). Максимальное количество аргументов в данной ситуации также равняется 255, и необходимо обязательно указывать один параметр функции.

Если говорить про функцию ИЛИ , то в случае с ней таблица истинности будет следующей.

Синтаксис формулы следующий:

=ИЛИ(Логическое значение 1; [Логическое значение 2];…)

Точно так же, как в предыдущем и последующем случае, каждый аргумент должен быть отделенным от другого с помощью точки с запятой. Если обратиться к приведенному выше примеру, то там каждый параметр возвращает «Истина», поэтому если необходимо при обращении к этому диапазону применять функцию «ИЛИ», то формула вернет «Истина» до тех пор, пока один из параметров не будет соответствовать определенному критерию.

Функция «Не»

Ею возвращаются те значения, которые являются противоположными по отношению к изначально заданному. То есть, при передаче в качестве параметра функции значения «Истина», вернется «Ложь». Если же соответствия не обнаружено, то «Истина».

То, какой результат будет выдан, зависит от того, какой исходный аргумент принимается функцией. Если, например, применять функцию «И» вместе с функцией «НЕ», то таблица будет следующей.

При использовании же функции «Или» в сочетании с функцией «Не», то таблица обретет такой вид.

Синтаксис этой функции очень прост: =НЕ(принимаемое логическое значение).

Эта функция по праву может называться одной из наиболее востребованных. Она проверяет определенное выражение на предмет соответствия конкретному условию. На результат влияет истинность или ложность данного утверждения.

Если говорить конкретно про эту функцию, то ее синтаксис будет несколько сложнее.

=ЕСЛИ(Логическое_выражение;[Значение_если_истина];[Значение_если_ложь])

Давайте более детально рассмотрим пример, который был приведен на скриншоте выше. Здесь в качестве первого параметра выступает функция ИСТИНА , которая проверяется программой. По результатам такого чекинга возвращается второй аргумент. Третий же опускается.

Пользователь может вкладывать одну функцию ЕСЛИ в другую. Это необходимо делать в тех случаях, когда в результате одной проверки на предмет соответствия определенному условию приходится делать еще одну.

Например, есть несколько кредитных карт, имеющих номера, начинающиеся первыми четырьмя цифрами, характеризующими платежную систему, обслуживающую карту. То есть, варианта два – Visa и Mastercard. Для проверки типа карты необходимо использовать такую формулу с применением двух вложенных ЕСЛИ .

=ЕСЛИ(ЛЕВСИМВ(A2;4)=”1111″; “Visa”;ЕСЛИ(ЛЕВСИМВ(A2;4)=”2222″;”Master Card”;”карта не определена”))

Если вы не знаете, что означает функция ЛЕВСИМВ , то она записывает в ячейку часть находящегося слева строки текста. Пользователь во втором аргументе этой функции задает количество символов, которые Excel должен выделить слева. Она используется для того, чтобы проверить, начинаются ли первые четыре знака номера кредитной карты с числа 1111. Если результат оказывается истинным, то возвращается «Visa». Если условие оказывается ложным, то используется функция ЕСЛИ .

Аналогично можно добиться приличной вложенности и проверять содержимое ячейки или диапазона на предмет соответствия нескольким условиям.

Читайте также  Складской учет в excel как сделать

Функция ЕСЛИОШИБКА

Необходима для того, чтобы определить, если ли ошибка. Если да, то возвращается значение второго аргумента. Если же все в порядке, то первого. Всего функция имеет два аргумента, каждый из которых обязательный.

Эта формула имеет следующий синтаксис:

Как можно использовать функцию?

В примере, приведенном ниже, видна ошибка в первом аргументе функции. Поэтому формула возвращает ответ, что запрещено деление на ноль. Первым параметром функции могут быть любые другие формулы. Человек может самостоятельно решать, какое содержимое может быть там.

Как могут использоваться логические функции на практике

Перед человеком поставлена цель осуществить переоценку товарных остатков. В случае хранения продукта в течение большего, чем 8 месяцев периода, необходимо снижать его стоимость в два раза.

Изначально нужно сформировать такую таблицу.

Для достижения поставленной цели необходимо использовать функцию ЕСЛИ . В случае с нашим примером будет так выглядеть эта формула:

Логическое выражение, содержащееся в первом аргументе функции, составлено с использованием операторов > и =. Простыми словами, изначально критерий следующий: при значении ячейки, большем или равном 8, выполняется формула, поставленная во втором аргументе. Выражаясь терминологическим языком, если первое условие оказывается истинным, то выполняется второй аргумент. Если же ложным – третий.

Сложность этой задачи может быть увеличена. Предположим, что перед нами стоит задача использовать логическую функцию И. В этом случае условие обретет следующий вид: в случае хранения продукции в течение большего, чем 8 месяцев срока, то его цену необходимо сбросить в два раза. Если же он находится на реализации больше 5 месяцев, то необходимо сбрасывать в 1,5 раза.

В этом случае необходимо в поле ввода формулы ввести такую строку.

=ЕСЛИ(И(C2>=8);B2/2;ЕСЛИ(И(C2>=5);B2/1,5;B2))

Функция ЕСЛИ допускает использование текстовых строк в аргументах, если это требуется.

Предположим, после того, как был товар уценен, он стал стоить меньше 300 рублей, то его необходимо списать. Это же нужно сделать, если он пролежал, не продаваясь в течение 10 месяцев. В этой ситуации допустим любой из этих вариантов, поэтому логично использовать функцию ИЛИ и ЕСЛИ . В результате, получится следующая строка.

Если при записи условия использовался логический оператор ИЛИ , то его необходимо расшифровывать следующим образом. Если в ячейке C2 находится число 10 или больше или если в ячейке D2 находится значение меньшее, чем 300, то необходимо выдать в соответствующей ячейке значение «списан».

Если же условие не выполняется (то есть, оказывается ложным), то формула автоматически возвращает пустое значение. Таким образом, если товар был продан ранее или лежит на складе меньше, чем необходимо, или он был уценен до значения, меньше порогового, то остается пустая ячейка.

Допускается применение и других функций как аргументов. Например, допустимо использование математических формул.

Предположим, есть несколько учеников, которые перед поступлением в гимназию сдают несколько экзаменов. В качестве проходного балла стоит оценка в 12. А чтобы поступить, обязательно необходимо, чтобы стояло хотя бы 4 балла по математике. В результате, Excel должен составить отчет о поступлении.

Для начала необходимо построить следующую таблицу.

Наша задача – сравнить сумму всех оценок с проходным баллом, а кроме этого убедиться, чтобы оценка по математике была ниже 4. И в графе с результатом необходимо указать «принят» или «нет».

Нам необходимо ввести следующую формулу.

С помощью логического оператора И необходимо проверить, насколько истинными являются эти условия. А чтобы определить итоговый балл, необходимо использовать классическую функцию СУММ .

Таким образом, с помощью функции ЕСЛИ можно решать множество различных задач, поэтому она является одной из наиболее часто встречаемых.

Предположим, перед нами появляется необходимость понять, сколько стоят товары после оценки в целом. Если стоимость продукта оказывается ниже, чем среднее значение, то необходимо списать этот товар.

Для этого можно использовать ту же таблицу, которая была приведена выше.

Чтобы решить эту задачу, необходимо использовать такую формулу.

В этом случае, допустим, нам необходимо определить средние продажи. Для этого необходимо составить такую таблицу.

Далее следует вычислить среднее значение тех ячеек, содержимое которых соответствует определенному критерию. Таким образом, необходимо использовать как логическое, так и статистическое решение. Под приведенной выше таблицей нужно составить вспомогательную, в которой будут отображаться результаты.

Эта задача может быть решена с использованием всего лишь одной функции.

В качестве первого аргумента используется диапазон значений, которые будут проверяться. Во втором указывается условие, в нашем случае это ячейка B9. А вот в качестве третьего аргумента используется диапазон, который будет применяться для того, чтобы осуществлять расчет среднего арифметического значения.

Функция СРЗНАЧЕСЛИ позволяет сравнить значение ячейки B9 с теми значениями, которые располагаются в диапазоне B2:B7, где перечисляются номера магазинов. Если данные совпадают, то формула подсчитывает среднее арифметическое диапазона C2:C7.

Логические функции необходимы в разных ситуациях. Существует множество видов формул, которые можно использовать для проверки на предмет соответствия определенным условиям. Как видно выше, основной функцией является ЕСЛИ , но существует множество других, которые можно использовать в различных ситуациях.

Также были приведены несколько примеров, как можно использовать логические функции в реальных ситуациях.

Существует еще множество аспектов применения логических функций, но тяжело их все рассмотреть в рамках одной, пусть даже большой, статьи. Нет предела совершенству, поэтому всегда можно искать новые варианты применения уже известных формул.

Источник:
http://office-guru.ru/excel/functions-logicheskie/logicheskie-operacii-v-excel.html

Логические функции Excel

Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые или логические значения. Любое логическое выражение должно содержать по крайней мере один оператор сравнения, который определяет отношение между элементами логического выражения. Ниже представлен список операторов сравнения Excel

= Больше или равно

Результатом логического выражения является логическое значение ИСТИНА (1) или логическое значение ЛОЖЬ (0).

Функция ЕСЛИ

Функция ЕСЛИ (IF) имеет следующий синтаксис:

=ЕСЛИ(логическое_выражение;значение_если_истина;значение_если_ложь)

Следующая формула возвращает значение 10, если значение в ячейке А1 больше 3, а в противном случае — 20:

В качестве аргументов функции ЕСЛИ можно использовать другие функции. В функции ЕСЛИ можно использовать текстовые аргументы. Например:

=ЕСЛИ(А1>=4;»Зачет сдал»;»Зачет не сдал»)

Можно использовать текстовые аргументы в функции ЕСЛИ, чтобы при невыполнении условия она возвращала пустую строку вместо 0.

Аргумент логическое_выражение функции ЕСЛИ может содержать текстовое значение. Например:

Эта формула возвращает значение 10, если ячейка А1 содержит строку «Динамо», и 290, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.

Функции И, ИЛИ, НЕ

Функции И (AND), ИЛИ (OR), НЕ (NOT) — позволяют создавать сложные логические выражения. Эти функции работают в сочетании с простыми операторами сравнения. Функции И и ИЛИ могут иметь до 30 логических аргументов и имеют синтаксис:

=И(логическое_значение1;логическое_значение2. )
=ИЛИ(логическое_значение1;логическое_значение2. )

Функция НЕ имеет только один аргумент и следующий синтаксис:

=НЕ(логическое_значение)

Аргументы функций И, ИЛИ, НЕ могут быть логическими выражениями, массивами или ссылками на ячейки, содержащие логические значения.

Приведем пример. Пусть Excel возвращает текст «Прошел», если ученик имеет средний балл более 4 (ячейка А2), и пропуск занятий меньше 3 (ячейка А3). Формула примет вид:

Если значение в ячейке А1 является целым числом, формула читается следующим образом: «Если значение в ячейке А1 равно 100, возвратить строку «Всегда». В противном случае, если значение в ячейке А1 находится между 80 и 100, возвратить «Обычно». В противном случае, если значение в ячейке А1 находится между 60 и 80, возвратить строку «Иногда». И, если ни одно из этих условий не выполняется, возвратить строку «Никогда». Всего допускается до 7 уровней вложения функций ЕСЛИ.

Функции ИСТИНА и ЛОЖЬ

Функции ИСТИНА (TRUE) и ЛОЖЬ (FALSE) предоставляют альтернативный способ записи логических значений ИСТИНА и ЛОЖЬ. Эти функции не имеют аргументов и выглядят следующим образом:

=ИСТИНА()
=ЛОЖЬ()

Например, ячейка А1 содержит логическое выражение. Тогда следующая функция возвратить значение «Проходите», если выражение в ячейке А1 имеет значение ИСТИНА:

В противном случае формула возвратит «Стоп».

Функция ЕПУСТО

Если нужно определить, является ли ячейка пустой, можно использовать функцию ЕПУСТО (ISBLANK), которая имеет следующий синтаксис:

=ЕПУСТО(значение)

Аргумент значение может быть ссылкой на ячейку или диапазон. Если значение ссылается на пустую ячейку или диапазон, функция возвращает логическое значение ИСТИНА, в противном случае ЛОЖЬ.

В начало страницы

В начало страницы

Источник:
http://on-line-teaching.com/excel/lsn024.html

10 формул в Excel, которые облегчат вам жизнь

Эти простые, но полезные функции могут пригодиться для самых разных задач.

Чтобы применить любую из перечисленных функций, поставьте знак равенства в ячейке, в которой вы хотите видеть результат. Затем введите название формулы (например, МИН или МАКС), откройте круглые скобки и добавьте необходимые аргументы. Excel подскажет синтаксис, чтобы вы не допустили ошибку.

Аргументами называют данные, с которыми работает функция. Чтобы добавить их, нужно выделить соответствующие ячейки или ввести необходимые значения в скобках вручную.

Есть и альтернативный способ указать аргументы. Если после названия функции добавить пустые скобки и нажать на кнопку «Вставить функцию» (fx), появится окно ввода с дополнительными подсказками. Можете использовать его, если вам так удобнее.

  • Синтаксис: =МАКС(число1; [число2]; …).

Формула «МАКС» отображает наибольшее из чисел в выбранных ячейках. Аргументами функции могут выступать как отдельные ячейки, так и диапазоны. Обязательно вводить только первый аргумент.

  • Синтаксис: =МИН(число1; [число2]; …).

Функция «МИН» противоположна предыдущей: отображает наименьшее число в выбранных ячейках. В остальном принцип действия такой же.

Сейчас читают 🔥

  • Синтаксис: =СРЗНАЧ(число1; [число2]; …).

«СРЗНАЧ» отображает среднее арифметическое всех чисел в выбранных ячейках. Другими словами, функция складывает указанные пользователем значения, делит получившуюся сумму на их количество и выдаёт результат. Аргументами могут быть отдельные ячейки и диапазоны. Для работы функции нужно добавить хотя бы один аргумент.

  • Синтаксис: =СУММ(число1; [число2]; …).

Эта простая, но очень востребованная функция подсчитывает сумму чисел в выбранных ячейках. Вы можете складывать как отдельные значения, так и диапазоны ячеек. Обязательным в формуле является лишь первый аргумент.

  • Синтаксис: =ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь]).

Формула «ЕСЛИ» проверяет, выполняется ли заданное условие, и в зависимости от результата отображает одно из двух указанных пользователем значений. С её помощью удобно сравнивать данные.

В качестве первого аргумента функции можно использовать любое логическое выражение. Вторым вносят значение, которое таблица отобразит, если это выражение окажется истинным. И третий (необязательный) аргумент — значение, которое появляется при ложном результате. Если его не указать, отобразится слово «ложь».

Читайте также  Печать шапки таблицы на каждой странице в Excel

6. СУММЕСЛИ

  • Синтаксис: =СУММЕСЛИ(диапазон; условие; [диапазон_суммирования]).

Усовершенствованная функция «СУММ», складывающая только те числа в выбранных ячейках, что соответствуют заданному критерию. С её помощью можно прибавлять цифры, которые, к примеру, больше или меньше определённого значения. Первым аргументом является диапазон ячеек, вторым — условие, при котором из них будут отбираться элементы для сложения.

Если вам нужно посчитать сумму чисел не в диапазоне, выбранном для проверки, а в соседнем столбце, выделите этот столбец в качестве третьего аргумента. В таком случае функция сложит цифры, расположенные рядом с каждой ячейкой, которая пройдёт проверку.

  • Синтаксис: =СЧЁТ(значение1; [значение2]; …).

Эта функция подсчитывает количество выбранных ячеек, которые содержат числа. Аргументами могут выступать отдельные клетки и диапазоны. Для работы функции необходим как минимум один аргумент. Будьте внимательны: «СЧЁТ» учитывает ячейки с датами.

  • Синтаксис: =ДНИ(конечная дата; начальная дата).

Всё просто: функция «ДНИ» отображает количество дней между двумя датами. В аргументы сначала добавляют конечную, а затем начальную дату — если их перепутать, результат получится отрицательным.

  • Синтаксис: =КОРРЕЛ(диапазон1; диапазон2).

«КОРРЕЛ» определяет коэффициент корреляции между двумя диапазонами ячеек. Иными словами, функция подсчитывает статистическую взаимосвязь между разными данными: курсами доллара и рубля, расходами и прибылью и так далее. Чем больше изменения в одном диапазоне совпадают с изменениями в другом, тем корреляция выше. Максимальное возможное значение — +1, минимальное — −1.

  • Синтаксис: =СЦЕП(текст1; [текст2]; …).

Эта функция объединяет текст из выбранных ячеек. Аргументами могут быть как отдельные клетки, так и диапазоны. Порядок текста в ячейке с результатом зависит от порядка аргументов. Если хотите, чтобы функция расставляла между текстовыми фрагментами пробелы, добавьте их в качестве аргументов, как на скриншоте выше.

Источник:
http://lifehacker.ru/formuly-v-excel/

Функция ЕСЛИ в EXCEL

11 апреля 2013 г.

Функция ЕСЛИ() относится к наиболее часто используемым функциям. Поэтому рассмотрим ее подробно.

Синтаксис функции

ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

Функция имеет 3 аргумента.

Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, выражение A1>100. Если в ячейке А1 содержится значение 102, то выражение A1>100 вернет ИСТИНА, т.к. 102>100. Если в ячейке А1 содержится значение 88, то выражение вернет ЛОЖЬ, т.к. неравенство 88>100 неверно. Полностью формула может выглядеть так =ЕСЛИ(A1>100;»Бюджет проекта превышен»;»ОК!») Если в ячейке A1 содержится значение большее 100, то формула вернет текстовое значение Бюджет проекта превышен, а если меньше 100 или равное 100, то будет выведено ОК!

Других значений кроме ИСТИНА или ЛОЖЬ логическое выражение вернуть не может. Любое число кроме 0 в первом аргументе будет преобразовано в ИСТИНА, ноль — в ЛОЖЬ. Если ошибочно будет указано текстовое значение, то функция вернет ошибку #ЗНАЧ!.

Примечание : Ошибка #ЗНАЧ! может быть также из-за ошибок в выражениях указанных во втором и третье аргументе.

Второй аргумент — Значение_если_истина и третий аргумент значение_если_ложь

Как было показано выше, если логическое выражение (первый аргумент функции) принимает значение ИСТИНА, то функция возвращает значение из второго аргумента значение_если_истина. Соответственно, если логическое выражение принимает значение ЛОЖЬ, то функция возвращает значение из третьего аргумента значение_если_ложь .

Второй и третий аргумент могут быть любым значением (число или текст) или являться выражением (формулой с функциями). Например формула =ЕСЛИ(A1>100;0;А1*1%) позволяет вычислять премию для проектов, в которых не было превышения бюджета (>100). Если бюджет превышен (в А1 введено значение 200 или любое другое более 100), то формула вернет 0, если в А1 введено значение менее 100, то будет вычислено значение премии А1*1% (т.е. если в А1 число 90, то формула вернет 0,9).

Если в качестве второго и третьего аргументов введено выражение, то оно может содержать и функции, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше или равно 100, то по столбцу С . Не забывайте, что при значении А1 = 100 в данном случае будет срабатывать выражение из аргумента значение_если_ложь.

Аргумент значение_если_ложь можно опустить (не вводить), тогда при значении логического выражения =ЛОЖЬ будет выведено ЛОЖЬ. Например, если в А1 содержится 600, то формула =ЕСЛИ(A1>=1000;»Больше или равно 1000″) вернет просто ЛОЖЬ. Понятно, что при значении логического выражения =ИСТИНА будет выведено «Больше или равно 1000», т.е. второй аргумент функции ЕСЛИ() — Значение_если_истина.

Вложенные ЕСЛИ

Для построения более сложных проверок в одной формуле можно использовать несколько функций ЕСЛИ(). Для этого в качестве значений аргументов значение_если_истина и значение_если_ложь введите еще одно условие с функцией ЕСЛИ(). Например, для проверки в какой диапазон попадает значение из ячейки А8 запишите формулу

  • Если значение из ячейки А8 менее 5, то будет выведено 1
  • Если значение из ячейки А8 более 10, то будет выведено 3
  • Если значение из ячейки А8 между 5 и 10 (включая 5 и 8), то будет выведено 2

Примечание : В версии EXCEL 2007 можно использовать до 64 вложенных друг в друга функций ЕСЛИ(). Но, пожалуйста, не делайте так. Такой подход чреват ошибками.

Примечание : Формулу =ЕСЛИ(A8 10;3;2)) можно переписать как =ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1) или ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1)

или более сложный вариант =ЕСЛИ(A8 10;3;2)) работает следующим образом: сначала вычисляется логическое выражение A8 =5, то EXCEL переходит к вычислению выражения ЕСЛИ(A8>10;3;2). Опять сначала вычисляется логическое выражение A8>10. Если оно истинно, то выводится 3, вычисления завершены. Если оно ложно, то выводится 2, вычисления завершены.

Чтобы грамотно написать формулу с вложенными ЕСЛИ() следуйте следующим простым правилам:

1) Определитесь с диапазонами:

1.1) они не должны пересекаться. В примере выше — 3 диапазона и значение из А8 гарантированно попадет только в один из них. Было бы ошибкой написать формулу типа =ЕСЛИ(A8 10;3;ЕСЛИ(A8 10;3;2)) на интересует вся числовая ось от минус бесконечности до +бесконечности. И все 3 диапазона полностью покрывают эту область.

1.3.) Не забудьте ставить знак равно, чтобы при значениях А8 совпадающих с границами интервалов не было неправильных вычислений. Например, если в формуле =ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1) забыть указать знак = в логическом выражении A8>=5, то при А8=5 формула =ЕСЛИ(A8>5;ЕСЛИ(A8>10;3;2);1) вернет 1, тогда как исходная формула вернет 2.

Примечание: В перечисленных выше случаях логические выражения вычисляются на основании одной переменной А8. Иногда нужно придумывать формулы с ЕСЛИ(), зависящие от 2-х и более ячеек: =ЕСЛИ(B8>=5;ЕСЛИ(A8>10;3;2);1). Это гораздо сложнее, но, конечно, возможно. Следуйте правилам 1.1)-1.3) и следите за диапазонами. Еще сложнее, если обе переменных являются зависимыми, т.е. например B8 вычисляется на основании А8. Написание таких формул требует предельной аккуратности и напрямую связано с корректностью формулирования самой задачи (возможно вы не продумали до конца как использовать такую сложную зависимость). Советую по возможности разбить вычисления на 2 или более формулы, чтобы проще контролировать результат вычисления.

2) Правильно записывайте логические выражения. Например, условие 5 10;3;2)) в строке формул можно записать как

Для этого поставьте курсор перед вторым ЕСЛИ(), нажмите и удерживайте клавишу ALT, нажмите ENTER.

4) для отладки вложенных ЕСЛИ вместо реальных вычислений (V8*10%-37500) используйте простые значения — последовательности 1; 2; 3 . Это покажет какой блок вложенных ЕСЛИ() срабатывает.

5) В ряде случаев от вложенных ЕСЛИ можно отказаться. Рассмотрим пример определения размера проекта от его бюджета

=ЕСЛИ(A1>=100;»Очень крупный проект»;
ЕСЛИ(A1>=90;»Крупный проект»;
ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы. Ниже приведено 2 эквивалентные формулы:

Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

Формула =ПРОСМОТР(A1;<0;50;90;100>;<"Малый проект";"Средний проект";"Крупный проект";"Очень крупный проект">) выглядит необычно, но по сути второй аргумент <0;50;90;100>, как и третий аргумент <"Малый проект";"Средний проект";"Крупный проект";"Очень крупный проект">это запись содержимого 4-х ячеек. Вместо <0;50;90;100>можно записать ссылку на диапазон ячеек, содержащих 4 значения 0;50;90;100. Круглые скобки нужны, чтобы сообщить, что в функцию передается не одно значение, а целый массив.

Еще пример. Пусть требуется вывести разный текст (например » 0″) в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0. Это можно сделать без вложенных ЕСЛИ():

Примечание : -1E+307 — это самое маленькое отрицательное число в EXCEL, 1E-307 — это самое маленькое положительное число. Таким образом задается 3 диапазона: от минус бесконечности до 0 (0 не включая); 0 (диапазон состоит только из одного значения 0); от 0 до +бесконечности (0 не включая).

Второй массив можно заменить ссылкой на диапазон, например для того чтобы вывести результат вычисления формул:

Диапазон A27:A29 должен, понятно, содержать формулы (см. файл примера).

Опущен третий аргумент [значение_если_ложь]

Третий аргумент функции не обязателен. Если логическое условие не выполнено, т.е. ЛОЖЬ, а третий аргумент функции не указан, то функция вернет также значение ЛОЖЬ. Например:

Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

Сложные логические выражения

В аргументе Лог_выражение можно использовать как простые сравнения типа F1>10, так и более сложные конструкции на основе функций И(), ИЛИ(), НЕ() и их комбинаций.

Основное правило — логические функции и их комбинации возвращают только одно из 2х логических значений: ЛОЖЬ или ИСТИНА.

Приведем несколько полезных примеров.

Формула =ЕСЛИ(ИЛИ(A1;A2);0;2) проверяет одновременность равенства значений А1 и А2 нулю. Если оба значения равны 0, то формула вернет 2. Во всех других случаях будет возвращен 0. А1 и А2 не должны быть пустыми ячейками.

Формула =ЕСЛИ(ИЛИ(A1=0;A2=0);0;2) проверяет равенство 0 хотя бы одного значения из А1 и А2.

Формула =ЕСЛИ(НЕ(A1>0);1;2) эквивалентна формуле =ЕСЛИ(A1 10″) . Аналогичный результат (23) можно получить с помощью формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный результат (2) можно получить с помощью формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))

Источник:
http://excel2.ru/articles/funkciya-esli-v-ms-excel-esli