Создание кроссворда в программе Microsoft Excel

Создание кроссворда в программе Microsoft Excel

Многие люди любят разгадывать кроссворды, есть так же лица, которым нравится их составлять. Иногда, составить кроссворд требуется не просто ради развлечения, а, например, чтобы проверить знания учащихся нестандартным способом. Но, мало кто догадывается, что отличным инструментом для создания кроссвордов является программа Microsoft Excel. И, действительно, ячейки на листе данного приложения, как будто специально предназначены для того, чтобы вписывать туда буквы отгадываемых слов. Давайте выясним, как быстро составить кроссворд в программе Microsoft Excel.

Создание кроссворда

Прежде всего, нужно найти готовый кроссворд, с которого вы будете делать копию в программе Excel, или же продумать структуру кроссворда, если вы будете придумывать его полностью сами.

Для кроссворда нужны квадратные ячейки, а не прямоугольные, как по умолчанию в Microsoft Excel. Нам нужно изменить их форму. Для этого, на клавиатуре нажимаем комбинацию клавиш Ctrl+A. Этим мы выделяем весь лист. Затем, кликаем правой кнопкой мыши, чем вызываем контекстное меню. В нём кликаем по пункту «Высота строки».

Открывается небольшое окошко, в котором нужно задать высоту строки. Устанавливаем значение 18. Жмем на кнопку «OK».

Чтобы изменить ширину, кликаем по панели с наименованием столбцов, и в появившемся меню выбираем пункт «Ширина столбца…».

Как и в предыдущем случае, появляется окошко, в которое нужно внести данные. На этот раз это будет число 3. Жмем на кнопку «OK».

Далее, следует подсчитать число клеточек для букв в кроссворде в горизонтальном и вертикальном направлении. Выделяем соответствующее количество ячеек на листе Excel. Находясь во вкладке «Главная», кликаем по кнопке «Граница», которая расположена на ленте в блоке инструментов «Шрифт». В появившемся меню, выбираем пункт «Все границы».

Как видим, границы, очерчивающие наш кроссворд, установлены.

Теперь, следует удалить эти границы в некоторых местах, чтобы кроссворд принял нужный для нас вид. Это можно сделать при помощи такого инструмента, как «Очистить», значок запуска которого имеет форму ластика, и находится в блоке инструментов «Редактирование» всё той же вкладки «Главная». Выделяем границы ячеек, которые хотим стереть и кликаем на данную кнопку.

Таким образом, постепенно прорисовываем наш кроссворд, поочередно удаляя границы, и получаем готовый результат.

Для наглядности, в нашем случае, можно выделить горизонтальную строку кроссворда другим цветом, например желтым, воспользовавшись для этого кнопкой «Цвет заливки» на ленте.

Далее, проставляем номера вопросов на кроссворде. Лучше всего, это делать не слишком большим шрифтом. В нашем случае, использован шрифт 8.

Для того, чтобы разместить сами вопросы, можно кликнуть любую область ячеек в стороне от кроссворда, и нажать на кнопку «Объединить ячейки», которая находится на ленте всё на той же вкладке в блоке инструментов «Выравнивание».

Далее, в большой объединенной ячейке можно пропечатать, или скопировать туда вопросы кроссворда.

Собственно, сам кроссворд на этом готов. Его можно распечатывать, или разгадывать прямо в Экселе.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Источник:
http://lumpics.ru/how-to-make-a-crossword-in-excel/

Способ, как в Excel сделать кроссворд

Кроссворд — это та головоломка, которую знают все. В настоящее время есть много вариаций данного развлечения, но одно сказать можно точно — кроссворды любят разгадывать многие. Из этого вытекает и то, что есть люди, которые любят их создавать.

Создание кроссворда может потребоваться в разных целях. Кто-то их делает для проверки знаний учащихся, а кто-то для себя и своих знакомых. Если же вы решили впервые создать собственную головоломку, то программа Excel вам в этом поможет.

Выравнивание ячеек

Итак, начинаем разбираться, как в Excel сделать кроссворд. Многие пользователи уже замечали, что табличный редактор Excel отлично подходит для создания кроссвордов, ведь в нем есть основное — клетки. Конечно, эти клетки не совсем верной формы, поэтому сейчас разберемся, как придать им правильный вид.

Чтобы изменить размеры в первую очередь необходимо выделить весь лист программы, чтобы изменения произошли везде. Для этого проще всего нажать сочетание клавиш CTRL+A.

После выделения в любом месте рабочей области нажмите правую кнопку мыши (ПКМ), чтобы открыть контекстное меню. В нем вам необходимо выбрать пункт «Высота строки». Появится маленькое окошко с полем для ввода, вам необходимо указать высоту строки в 18 пунктов и нажать кнопку «ОК».

Итак, высоту мы указали, но клетки все ровно еще не правильной формы — нужно изменить ширину. Для этого, не сбрасывая выделения, нажмите ПКМ по названию столбца, например, по столбцу F. В контекстном меню соответственно выберите «Ширина столбца». В появившемся окне введите число 3 и нажмите кнопку «ОК».

Как можно заметить, размер ячеек стал квадратным, что нам и нужно было. Но это лишь первый этап, как в Excel сделать кроссворд. Дальше будет посложнее. Кстати, размер ячеек вы можете задавать собственный, однако соблюдайте пропорции.

Создание клеток

Составить кроссворд без клеток — невозможно, поэтому следующим этапом будет их создание.

Изначально определитесь с формой самого кроссворда. Вы можете использовать как другой для образца, так и свой собственный. Посчитайте, какую область он занимает, и отмерьте ее в программе. Допустим, кроссворд занимает 11 на 9 ячеек, соответственно выделяем эту область.

Теперь необходимо задать границы, для этого используем одноименный инструмент, который находится во вкладке «Главная» в разделе «Шрифт». Нажав на стрелочку рядом, появится выпадающий список, в котором выберите «Все границы».

Читайте также  Как сделать файл vcf из excel?

Итак, клетки есть, но их слишком много. Поэтому следующим этапом будет отсечение лишнего. Помните: чтобы понять, как в Excel сделать кроссворд, вам нужно дочитать статью до конца.

Создание формы кроссворда

Из массы наших клеток нужно убрать те, что мешают. Для этого очень удобно использовать инструмент «Очистить», который находится на панели инструментов в разделе «Редактирование», на все той же вкладке «Главная». К слову, инструмент этот имеет картинку ластика.

Все что вам нужно будет сделать — это поочередно выделять лишние клетки и нажимать на инструмент «Очистить». Если при нажатии у вас будут спрашивать, каким именно методом проводить очистку, то выбирайте «Очистить все».

В итоге у вас должна получиться та форма, которая изначально задумывалась. Как только вы этого достигнете, переходите к следующему шагу.

Добавление нумерации

Теперь нужно пронумеровать нужные клетки кроссворда. Сделать это можно двумя способами: вводить номера в сами клетки или нумеровать клетки рядом. В примере мы воспользуемся вторым вариантом, так как для данного кроссворда это подходит лучше.

Все что необходимо сделать, это выделить нужную ячейку, ввести соответствующую цифру и нажать ENTER. Однако цифры могут быть слишком большими или, наоборот, маленькими, поэтому задайте им нужный размер. Если вы делали кроссворд в точности, как указано в статье, то отлично подойдет размер шрифта «8».

К слову, чтобы нумерация смотрелась лучше, можно разместить цифру в одном из углов, например, в нижний правый. Для этого выделите нужную ячейку и на панели инструментов, во вкладке «Главная», нажмите поочередно две кнопки «Выравнивание по нижнему краю» и «Выравнивание по правому краю». Данные кнопки располагаются в группе инструментов «Выравнивание».

В конце у вас должно получиться примерно так же, как показано на изображении ниже.

Также не забывайте, что вы можете импровизировать, меняя размер как самих клеток, так и шрифта. Вы можете также полностью изменить шрифт или поменять расположение номеров.

Ввод вопросов

Кроссворд в Excel уже почти создан, осталось лишь вписать вопросы, на которые необходимо будет отвечать. Сделать это очень просто. Изначально определитесь, где будут они вписаны. Можно справа, слева, сверху или снизу самой головоломки — решать лишь вам. Но в примере будут справа.

Первым делом выделите примерную область, которую займут вопросы, и нажмите на кнопку «Объединить». Данная кнопка расположена во вкладке «Главная», в группе «Выравнивание». Из выпадающего меню выберите «Объединить ячейки».

Теперь вам нужно вписать сами вопросы, не забыв вначале поставить их номер. Вот и все, теперь вы знаете, как в Excel сделать кроссворд.

Источник:
http://fb.ru/article/314739/sposob-kak-v-excel-sdelat-krossvord

Пошагово как сделать кроссворд в Excel

Почти всем нравится разгадывать кроссворды. Поэтому они могут быть полезными в разных областях жизни. Например, в онлайн-бизнесе. Пользователя можно привести на сайт, заинтересовав такой мини-игрой. Кроссворды полезны и в преподавательской деятельности, поскольку с их помощью можно закрепить или проверить усвоенные знания.

Например, они используются в современных курсах английского языка, где дается определение, и нужно соответствующее ему слово записать в определенной строчке.

А с помощью Excel можно автоматизировать заполнение кроссвордов. Как вариант, показывать корректные ответы и проверять ученика, выставляя ему оценку.

Как нарисовать кроссворд в Excel

Чтобы нарисовать кроссворд в Excel, необходимо нажать комбинацию Ctrl+A (с ее помощью можно выделить все), а потом открыть путем нажатия правой кнопкой мыши контекстное меню. Затем следует левой кнопкой кликнуть по строчке «Высота строки» и выставить ее на уровне 18.

1

Чтобы определить ширину столбца, необходимо нажать левой кнопкой мыши по правому краю ячейки и перетащить его вправо.

Зачем это делать? Причина кроется в том, что ячейки в Excel изначально имеют прямоугольную форму, а не квадратную, в то время как для нашей задачи нужно сделать высоту и ширину одинаковыми. Поэтому необходимо ячейки, которые отводятся под эту игру, сделать соответствующей формы.

2

Затем необходимо выделить те ячейки, которые будут отводиться под строки. После этого ищем группу «Шрифт», где выставляем все границы. Также можно окрасить ячейку определенным образом, если есть такое желание.

В правой части листа необходимо сделать длинные строчки, где будут записываться вопросы к нему. Не стоит забывать о том, чтобы выставить возле соответствующих строк цифры, соответствующие номерам вопросов.

Программирование кроссворда

Чтобы научить кроссворд определять, какие ответы верные и выставлять пользователю оценку, необходимо создать дополнительный лист с перечислением правильных ответов.

3

На этом скриншоте видно, что основные колонки три:

  1. Ответы. Здесь перечислены верные ответы.
  2. Введено. Здесь автоматически записываются те ответы, которые ввел пользователь.
  3. Знак вопроса. Здесь указывается оценка 1, если человек ответил правильно и 0, если неправильно.

Также в ячейке V8 будет итоговый балл.

Далее следует применять функцию « Сцепить », чтобы склеить отдельные буквы в кроссворде. Это необходимо для появления целого слова в этой строке. Вводить формулу нужно в ячейку столбца «Введено».

4

Основная проблема в том, что человек может писать как большие, так и маленькие буквы. Из-за этого программа может подумать, что ответ неправильный, хотя он верный. Чтобы решить эту проблему, необходимо воспользоваться функцией СТРОЧН , в которую и вводится функция СЦЕПИТЬ , как показано в этой строке кода.

Эта функция приводит все буквы в один вид (то есть, превращает их в строчные).

Далее необходимо запрограммировать условие. При верном ответе, должна получиться единица, а неверном – 0. Для этого используется встроенная функция Excel ЕСЛИ , вводимая в ячейку колонки «?».

5

Чтобы вывести итоговую оценку в ячейку V8, необходимо воспользоваться функцией СУММ .

6

В нашем примере максимально предусмотрено 5 правильных ответов. Идея такая: если эта формула возвращает цифру 5, то появится надпись «Молодец». При более низком балле – «Еще подумай».

Чтобы это сделать, снова нужно использовать функцию ЕСЛИ , введенную в ячейку «Всего».

Также в функционал можно добавить возможность показать количество вопросов, которые нужно решить. Поскольку максимальное количество вопросов в нашем примере – 5, то нужно в отдельной строке написать такую формулу:

=5-‘Лист1 (2)’!V8, где ‘Лист1 (2)’!V8

Чтобы убедиться, что ошибок в формулах нет, необходимо ввести ответ в какую-то строчку кроссворда. Укажем ответ «дисковод» в строку 1. В результате, получится следующее.

7

Необходимо сделать так, чтобы игрок не был в курсе, какой ответ правильный. Их нужно удалить из сетки кроссворда на вспомогательном листе, но оставить его в файле. Для этого необходимо открыть вкладку «Данные» и найти группу «Структура». Там будет находиться инструмент «Группировать», который и следует использовать.

8

Откроется диалог, где напротив записи «Строки» ставится флажок. Слева всплывут значки структуры с символом минуса.

9

Если на него нажать, данные скроются. Но опытный пользователь Excel может легко открыть правильные ответы. Для этого их нужно защитить паролем.

Необходимо найти вкладку «Рецензирование», где найти группу «Изменения». Там будет кнопка «Защитить лист». Ее нужно нажать. Далее появится диалоговое окно, в котором нужно записать пароль. Все, теперь сторонний человек, который не знает его, не сможет найти правильный ответ. Если он попытается это сделать, Excel предупредит его, что лист защищенный, и данная команда запрещена.

Все, кроссворд готов. Далее его можно стилизовать с помощью стандартных методов Excel.

Как составить эффективный учебный кроссворд?

Кроссворд – это эффективный метод, позволяющий повысить степень самостоятельности учеников в процессе обучения, а также повысить мотивацию к этому процессу. Кроме этого, он позволяет хорошо разобраться в терминах изучаемого предмета.

Чтобы составить эффективный кроссворд для обучения, необходимо следовать таким рекомендациям:

  1. Нельзя допускать наличие пустых ячеек внутри кроссворда.
  2. Все пересечения нужно продумывать заранее.
  3. Нельзя использовать в качестве ответов слова, не являющиеся именами существительными в именительном падеже.
  4. Ответы должны формулироваться в единственном числе.
  5. Если слова состоят из двух букв, то требуется два пересечения. Вообще, желательно минимизировать частоту двухбуквенных слов.
  6. Нельзя использовать короткие слова (детдом) или аббревиатуры (ЗиЛ).

Как можно использовать кроссворд в Excel во время обучения?

Использование современных технологий во время обучения способно не только помочь ученикам более активно вовлечься в процесс, изучить предмет, но и повысить уровень своей компьютерной грамотности. В последнее время очень популярным направление в обучении является STEM, который предусматривает интеграцию науки, технологий, инженерии и математики в одном курсе.

Как это может выглядеть на практике? Например, изучается какой-то предмет, например, астрономия (наука). Ученики учат новую терминологию, которую затем повторяют с помощью кроссворда Excel (технологии). Здесь же потом можно ученикам рассказать, как создать такой кроссворд. Потом попробовать создать телескоп, используя математические формулы.

Вообще, терминология – один из наиболее сложных аспектов изучения любой дисциплины. Некоторые из них очень сложны для усвоения, а игровой элемент создает дополнительную мотивацию, которая способствует появлению новых нейронных связей в мозгу. Этот механизм в психологии называется положительным подкреплением. Если ребенку интересно, он будет с большей охотой вовлекаться в изучаемый материал.

Чем ребенок старше, тем более разнообразными должны быть задания, терминологический аппарат может больше смещаться в сторону абстрактных понятий, а дифференциация заданий по сложности может быть более выраженной.

Читайте также  КАК: Создание пиктограммы

Но это только один из большого количества методов использования кроссвордов в обучении. Если говорить более конкретно, то он может применяться для:

  1. Домашних заданий учащимся. У учеников вырабатывается умение самостоятельно разбираться в учебном материале, формулировать вопросы, а также развиваются творческие способности учеников.
  2. Работы непосредственно во время занятия. Кроссворды – это очень удобный метод повторения материала прошлого занятия. Он позволяет быстро систематизировать полученную информацию, на фундаменте которой будет строиться новый материал.

Создание кроссворда в Excel на уроке или в качестве домашнего задания имеет еще одно важное преимущество – таким образом значительно проще выучить определенный материал. Когда ученик самостоятельно придумывает вопросы к конкретному термину, у него в мозгу выстраиваются нейронные связи, которые помогают понять тему и использовать полученные знания в дальнейшем.

Этапы составления учебного кроссворда в Excel

  1. Для начала необходимо определиться с видом кроссворда. Рекомендуется использовать нестандартные формы. Благо, Excel имеет достаточно инструментов, чтобы разработать любой дизайн. Важно, слова должны располагаться свободно друг от друга.
  2. Затем нужно написать перечень терминов и определений к ним. Желательно использовать как простые, так и сложные слова.
  3. Этап оформления поля, проставление нумераций.
  4. Программирование кроссворда (при необходимости).

Способы программирования оценки результата

Кроме описанного выше метода (общее количество правильных ответов), можно также использовать баллы с весовыми коэффициентами. В таком случае нужно нарисовать еще одну колонку, где прописываются весовые коэффициенты возле каждого вопроса, а также. Также необходимо добавить столбец с общим результатом. В таком случае ячейка всего должна являть собой сумму взвешенных оценок.

Такой способ подсчета оценки больше подходит, если есть несколько разных по сложности полей. Естественно, количество правильных ответов здесь не будет объективным показателем.

Каждый балл, поставленный в колонке «?» необходимо умножить на весовой коэффициент, который стоит в следующем столбце и вывести далее взвешенное значение.

Можно оценивание сделать в виде индивидуального рейтинга. Тогда в качестве оценки используется процент отгаданных слов.

Плюсы и минусы составления кроссвордов в Excel

Главное преимущество – не нужно осваивать дополнительные программы. При этом этот метод имеет ряд серьезных недостатков. Excel создавался для других задач. Поэтому для составления кроссвордов в электронных таблицах придется совершить больше ненужных действий, чем если использовать специальные программы. Некоторые позволяют сделать это в режиме он-лайн, а потом поделиться полученным результатом с другими людьми.

Создание кроссвордов в Excel – процесс трудоемкий и долгий. Использование других программ позволяет значительно ускорить этот процесс. Впрочем, для него достаточно всего лишь базовых навыков владения электронными таблицами.

Использование кроссворда в Excel в бизнесе

Предпринимательская деятельность требует некоторой изобретательности. Например, можно предложить клиенту заполнить кроссворд, и если у него это получится сделать, дать ему приз. В свою очередь, этот презент может стать отличным элементом воронки продаж. Когда он его получит, можно предложить ему расширенную или улучшенную версию определенного продукта, но уже за деньги.

Впрочем, в бизнесе использование Excel-кроссвордов не настолько широко распространено. Основной недостаток такого подхода заключается в том, что такой же кроссворд можно реализовать стандартными средствами HTML и Javascript. А используя специальные приложения можно легко создать подобный инструмент в визуальном редакторе и не требуется скачивать отдельный документ на компьютер.

Таким образом, создание кроссворда в Excel не требует особых умений и навыков. Достаточно просто особым образом стилизовать его, а также ввести несколько формул, чтобы таблица автоматически проверяла правильность ответов.

Он может использоваться как в бизнесе, так и во время учебного процесса. В последнем случае пространство для применения кроссвордов значительно больше. Они могут использоваться и для проверки знаний учеников, и для обучения компьютерной грамотности, и для изучения терминологического аппарата определенной дисциплины.

Источник:
http://office-guru.ru/excel/prochee-excel/poshagovo-kak-sdelat-krossvord-v-excel.html

Делаем кроссворд в Excel

Составление кроссвордов в программе Microsoft Excel более желательно, нежели проделывание подобной процедуры в Word. Дело в том, что функционал Excel позволяет создать этот сканворд быстрее, плюс, имеется возможность создать проверку для кроссворда. В Word такой возможности.

Ранее мы уже разбирали, как создать кроссворд в MS Word. Рекомендуем ознакомиться с этой статьёй для лучшего понимания.

Как создать кроссворд в Excel

Для начала лучше обдумать структуру кроссворда заранее и начертить её где-нибудь на бумаге. Можно найти в сети уже готовый сканворд и скопировать его структуру. Когда всё будет готово переходите в интерфейс Excel.

Этап 1: Создаём сканворд

Задать саму структуру будущего кроссворда можно, если выполнить следующие действия:

  1. Запустите Excel. Как видите, ячейки здесь прямоугольные. Они не подходят для создания кроссворда, поэтому придётся поменять их форму. Выделите вся ячейки на листе, воспользовавшись сочетанием клавиш Ctrl+A.
  2. Нажмите правой кнопкой мыши по выделению. Из контекстного меню выберите вариант «Высота строки».

Откроется окошко с настройками высоты строки. Здесь задайте любое удобное вам значение, но не сильно большое. Например, мы установим высоту в 20 единиц. Жмите «Ок» для применения изменений.

  • Теперь кликните правой кнопкой мыши по названию любого столбца. Из контекстного меню выберите вариант «Ширина столбца».
  • Установите здесь значение 3 и нажмите «Ок».

  • Определитесь с размером кроссворда в вертикальном и горизонтальном положении. Сделайте выделение области в соответствии с тем, сколько клеток вы запланировали в сканворде.
  • Теперь в верхней строке, в блоке инструментов «Шрифт», кликните по кнопке «Граница». Из контекстного меню выберите «Все границы».

    Границы, которые очерчивают сканворд успешно установлены. Теперь выделите те его части, которые не нужны в кроссворде, то есть куда ничего не будет вписываться. В блоке инструментов «Редактирование» нажмите на кнопку в виде ластика. Таким образом вы удалите выделение у тех участков, где оно не требуется.

  • Дополнительно можно выделить каким-нибудь акцентным цветом главную полосу кроссворда. Выделите эту полосу и измените у неё цвет с помощью инструмента заливки, что расположен в блоке «Шрифт».
  • Основная структура кроссворда готова, теперь осталось только пронумеровать строки и столбцы, а также прописать вопросы в отдельном блоке.

    1. Выделите ячейку около нужной строки/столбца. Поставьте в ней номер данной ячейки. Если цифра номера слишком большая, то вы можете уменьшить её, выбрав соответствующий размер в блоке инструментов «Шрифт». Также можно настроить выравнивание цифры в соответствующем блоке.
    2. Теперь нужно выделить область, в которую будут записаны вопросы. Её размер может быть произвольным, главное, чтобы все данные поместились в указанной области.
    3. В выделенной области нужно убрать разбиение на ячейки. Нажмите по ней правой кнопкой мыши и выберите из контекстного меню «Объединить ячейки».

  • Вставьте туда заранее подготовленный текст или пропишите вопросы вручную.
  • Этап 2: Проверка правильности

    Вы можете также сделать проверку кроссворда в Excel. Правда, она будет доступна только для тех пользователей, которые разгадывают его в электронном виде. Для печати функция проверки недоступна.

    Делается проверка готового кроссворда следующим образом:

    1. Создайте дополнительный лист для таблицы. Здесь запишите ответы в формате таблицы. Разделите её на столбцы:
      • «Ответы». Сюда вписываются сами ответы на вопросы;
      • «Введено». В этом столбце вписываются данные, которые пользователь ввёл;
      • «Совпадения». Здесь Excel будет сверять данные введённые пользователем с ответами;
      • Ещё внизу можно создать блок «Итого», где будет подсчитана сумма верных ответов.

  • Переключитесь на первую ячейку столбца «Введено». Здесь нужно задать специальную функцию. Нажмите на кнопку в виде буквы «f» около строки ввода данных.
  • Будет открыт мастер создания функций. В нём найдите функцию, которая называется «Сцепить». Выберите её и нажмите «Ок», чтобы она применилась.

  • Откроется окошко задания аргументов для функции. Здесь нужно нажать на кнопку в виде таблички, что расположена около строки ввода аргумента.
  • Переключитесь на первый лист и выберите все ячейки той строки, которая соответствуют нужному вопросу.
  • Проделайте аналогичную операцию с другими ответами.

    Теперь переключитесь на первую ячейку совпадений. Сюда нужно задать функцию «Если». Она будет иметь следующий вид: «=ЕСЛИ(номер_ячейки_ответа=номер_ячейки_введено;1;0)». Вот так она выглядит у нас: «=ЕСЛИ(A4=B4;1;0)». То есть, если ответ пользователя совпадает с записанным в таблице ответом, то в «Совпадение» пишется один балл. В противном случае ставится 0.

  • Переключитесь к строке «Итого». Здесь нужно прописать функцию «СУММ», чтобы суммировать полученные баллы. В скобках этой функции проставьте номера ячеек, которые требуется просуммировать.
  • Осталось только вписать завершающую функцию на первом листе с кроссвордом, которая будет выдавать, правильно ли он решён или нет.

    1. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу. Именно от этого числа нужно будет составлять дальнейшую формулу.
    2. Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

    Теперь, если пользователь ответил на один или несколько вопросов неверно, то система предложит ему подумать ещё. В противном случае Excel оповестит человека о том, что он решил кроссворд правильно.

    Источник:
    http://public-pc.com/delaem-krossvord-v-excel/

    Как сделать в Excel кроссворд

    Программы из пакета Mircosoft Office предназначены для работы с документами в самых разных их проявлениях. За время, прошедшее с момента запуска пакета и до сегодняшнего дня, каждая из этих программ обросла множеством полезных и важных функций, так что пользователь может выполнить практически любую операцию всего парой нажатий мышью.

    Специальные функции позволяют автоматизировать процесс работы

    Однако есть вещи, которые сделать не так просто. Например, в Excel — программе для работы с таблицами — компания встроила механизм функций, которые может использовать пользователь. С их помощью можно обрабатывать самые разные данные. Но автору придётся лично выстраивать модель взаимодействия, вводя формулы и указывая диапазоны данных.

    Нужно учитывать также то, что перед пользователем встают иногда весьма нетривиальные задачи — как, например, создать кроссворд в Excel. Понятно, что в самой программе такой функции нет, так что нужно будет кое-что всё же выполнить вручную.

    Первый этап

    Перед тем как начать создание кроссворда с проверкой в Excel, вам нужно определиться со списком вопросов и ответов. Мы рекомендуем завести для этого отдельный файл и сразу вписать строчки так, как они должны выглядеть в результате работы. После этого откройте программу; необходимо создать новую книгу, если она не создаётся автоматически. Это нужно потому, что наш способ будет использовать одновременно два рабочих листа, поэтому целесообразно выделить их в отдельный файл. Итак, переименуем «Лист 1» так, как вам удобно. По сути, его имя может быть произвольным, главное, чтобы вы его потом не меняли. На этом листе с помощью границ нужно нарисовать контур будущего кроссворда.

    Выделяем ячейки по горизонтали или вертикали, находим в ленте настроек вкладку «Разметка страницы» и нажимаем на кнопку «Границы». Если вам недостаточно появившихся на экране вариантов, смело выбирайте свои в одноимённом пункте. Теперь на листе у нас появился контур одного из слов. Нужно повторить это столько раз, сколько вопросов вы хотите включить в своё творение. Не забывайте ставить числа в первые ячейки, чтобы потом не пришлось вспоминать, какое именно слово должно быть сюда вписано.

    Если вам не нужно делать кроссворд с проверкой, Excel можно закрывать, так как на этом собственно рисование заканчивается. Вы можете, например, вставить его в Ворд или просто распечатать, чтобы получить на листе бумаги нарисованную сетку с пересечениями в нужных местах. При должной сноровке вы можете даже «Заливкой ячейки» закрасить некоторые из них чёрным цветом, чтобы получить стилизацию под напечатанный в газете кроссворд. Однако это самый простой вариант.

    Второй этап

    Если проверять впечатанные пользователем слова всё же нужно, придётся немного схитрить. Дело в том, что фоновую проверку слов, чтобы пользователь её не видел, можно осуществить разве что с помощью макросов. Но если воспользоваться встроенными средствами Excel, то можно добиться похожего результата. Для этого скопируйте лист с кроссвордом, щёлкнув по нему правой кнопкой мыши. Полученный лист переименуйте (имя тоже может быть произвольным). В клетки кроссворда, сделанного на втором листе Excel, впишите ответы — это нужно будет для проверки правильности введённых пользователем букв.

    Теперь рядом с кроссвордом сделайте небольшую табличку из двух столбцов. В первом будет указан номер вопроса, во втором — результат отгадки. Используем интуитивно понятную систему: 1 — если ответ правильный, и 0 — во всех остальных случаях. Наш кроссворд не будет учитывать сделанные пользователем опечатки, так что они тоже будут туда попадать.

    Теперь нужно в ячейки второго столбца нашей проверочной таблицы добавить формулу. Её суть в том, чтобы сравнивать диапазон ячеек на первом листе с аналогичным диапазоном на втором. Диапазоны — слова в кроссворде. Если они совпадают, то в столбец на этой строке заносится единица, если нет — ставится ноль. Провести такую проверку можно с помощью оператора сравнения, формула в общем виде будет выглядеть примерно так: =ЕСЛИ((Кроссворд.D1=Ответ.D1) И (Кроссворд.D2=Ответ.D2) И … ) ТО 1 ИНАЧЕ 0.

    Как видите, она не очень-то сложная, правда, выстраивать диапазон ячеек вам нужно очень внимательно. Кстати, именно для того, чтобы сделать кроссворд с проверкой в Excel, мы копировали заполненный кроссворд на второй лист. Это гарантирует, что ячейки на проверочном листе находятся по тем же адресам, что и на основном.

    Последние штрихи: на листе с кроссвордом можно сделать счётчик количества правильно отгаданных слов, чтобы пользователь ориентировался в нём. Для этого просто суммируем данные из второго столбца проверочной таблицы. Ну, и осталось только скрыть этот лист, щёлкнув по нему правой кнопкой мыши и выбрав одноимённый параметр.

    Заключение

    Решение этой, на первый взгляд нетривиальной задачи на поверку оказывается не таким уж сложным. Используя гибкость встроенных функций Excel, вы можете создавать кроссворды как с проверкой, так и без неё, причём делать это так, как считаете нужным. Ведь мы описали только один из возможных способов.

    Источник:
    http://nastroyvse.ru/programs/review/kak-sdelat-krossvord-excel.html

    Кроссворды в excel как сделать

    Проверка правильности решения кроссворда.

    Чтобы проверить, правильно ли ученик заполнил кроссворд, нужно сравнить каждое введенное слово с образцом – правильным ответом. Иначе говоря, для каждого слова мы будем сравнивать значения двух ячеек – с введенным словом и правильным ответом, и если они равны, помечать это слово как «верно».

    Запишем на свободном месте листа Excel правильные ответы (потом эта информация будет скрыта).

    Но если правильный ответ представляет из себя целое слово, записанное в одной ячейке, то ответ ученика – это совокупность нескольких ячеек, в каждой из которых записано по одной букве. Поэтому мы должны ответ ученика преобразовать так, чтобы его можно было сравнить с правильным ответом, то есть соединить отдельные буквы из разных ячеек в целое слово, записанное в одной ячейке. Для этого будем использовать функцию для текстовых величин СЦЕПИТЬ.

    · Выделите ячейку, в которой будет записан преобразованный ответ ученика (в моем примере это ячейка, в которой записаны ответы студента ).

    · В данной ячейке введите формулу (наберите с клавиатуры или воспользуйтесь командой Вставить функцию на вкладке Формулы): =СЦЕПИТЬ ( ячейка с первой буквой слова; ячейка со второй буквой слова ; ячейка с третьей буквой слова ; т.д.; ).

    Теперь можно сравнить правильный ответ с ответом ученика. Для этого будем использовать функцию ЕСЛИ: если слова совпадут, напишем напротив ответа «1», если нет «0». Мы используем числовые значения, а не слова «верно» — «неверно», потому что в дальнейшем проще будет подсчитать количество правильно угаданных слов.

    Введите в ячейку : =ЕСЛИ(ячейка с правильным ответом=ячейке с ответом студента;1;0).

    С помощью маркера автозаполнения копируем формулу по столбцу на весь необходимый диапазон.

    · Ниже напишите «Количество правильных ответов» и введите в соседнюю ячейку формулу: = СУММ(первая ячейка с правильностью ответов: последняя ячейка с правильностью ответов )

    Скройте все строки с ответами ученика, правильными ответами и количеством угаданных слов.

    Пусть в процессе разгадывания кроссворда на экране высвечивается комментарий «Отлично!», «Хорошо!», «Пока на «троечку»», «Пока не угадано ни одного слова». Для этого введите в ячейку формулу:

    =ЕСЛИ(ячейка с количеством отгаданных слов=0;»Пока не угадано ни одного слова»;ЕСЛИ( ячейка с количеством отгаданных слов <17;"Пока на троечку";ЕСЛИ( ячейка с количеством отгаданных слов <20;"хорошо!";"отлично!")))

    Создадим кнопку для очистки ячеек кроссворда с использованием макроса.

    Нажмите кнопку « Office » , затем «Параметры Excel », выберите в списке с левой стороны открывшегося окна «Настройка», затем из списка вкладок выберите «Разработчик».

    В списке команд найдите «Элементы управления» и нажмите кнопку «Добавить», затем кнопку «ОК». Кнопка «Элементы управления» будет добавлена на панель быстрого доступа.

    На панели быстрого доступа нажмите кнопку «Элементы управления», «Вставить», «Элементы управления формы», «Кнопка».

    Нарисуйте кнопку. Автоматически откроется окно «Назначить макрос объекту». Нажмите на кнопку «Записать», затем «ОК».

    Выделите последовательно все клетки кроссворда и удалите из них буквы.

    На вкладке Вид выберите Макросы- Остановить запись.

    Теперь щелчок левой кнопкой мыши будет запускать макрос, а щелчок правой кнопкой – вызывать контекстное меню.

    Чтобы изменить название кнопки, выберите в контекстном меню «Изменить текст» и введите свое название (Очистить кроссворд).

    Для правильного функционирования макроса не забудьте перед работой уровень безопасности макроса выбрать Низкий: кнопка Office – Параметры Excel – Центр управления безопасности – Параметры центра – управление безопасностью – Параметры макросов – Включить макросы.

    Проверьте работу кроссворда (выставление оценки и кнопку очистки кроссворда).

    Источник:
    http://www.sites.google.com/site/herzencomputerscience/sozdanie